1995 SL 320 Check Engine Light - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-20-2014, 02:54 PM Thread Starter
BenzWorld Newbie
 
PJ's SL 320's Avatar
 
Date registered: Feb 2014
Vehicle: 1995 SL 320
Location: Elbert, CO
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1995 SL 320 Check Engine Light

HELP! I have only had my car for a few months, but can't seem to keep the Check Engine light out for more than a few hundred miles at a time after resetting at the shop. The only thing the engine does, at times, is start hard when hot (turns over quite a bit before firing, and then can smell gas). All other times everything is normal. So far the codes and fixes have not helped.
PJ's SL 320 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-20-2014, 03:00 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,048
Mentioned: 18 Post(s)
Quoted: 922 Post(s)
Lifetime Premium Member
What are the codes and what have you tried fixing/replacing?
Noodles is offline  
post #3 of 4 (permalink) Old 02-20-2014, 05:02 PM Thread Starter
BenzWorld Newbie
 
PJ's SL 320's Avatar
 
Date registered: Feb 2014
Vehicle: 1995 SL 320
Location: Elbert, CO
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
My shop has cleaned an EGR pipe but it keeps coming back with that code, don't know the number myself. They say the system that is coding is OK, so now they think it might be the code sensor itself. But the hard warm starting? Don't see how a bad sensor could cause that.

Also, the shop did replace a $170 valve that purges the fuel tank? That was no help.
PJ's SL 320 is offline  
post #4 of 4 (permalink) Old 02-20-2014, 07:07 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,756
Mentioned: 9 Post(s)
Quoted: 1120 Post(s)
You have first generation of computerized engine management and the sensors from 1990's don't have good reliability records.
Still you should find qualified mechanic who can deal with it.
Without the codes, all we can do is to give you moral support.
Kajtek1 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome