E320 211 seat draining battery help - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-25-2013, 06:04 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2013
Vehicle: 2003 E320 211
Location: USA
Posts: 3
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Red face E320 211 seat draining battery help

2003 E320 4 door
Short story is: there is a 2.2 amp drain on my battery when fuse 34 is in place & when the network should be asleep. If I pull fuse 34 I have 80 ma draw and no driver seat action.

I would like to avoid the dealership and I have no present ability to scan. I would like to see if I can solve this by process of elimination and logic. If not I will by a Benz scanner$$$$ but first I must try. I can diagnose and solve electrical problems, I do it for a living in the form of building HVAC controls. I have moved from a W126 to this W211 and have no previous experience with this car so please help.

I suspect that the controller to the driver's seat's motors is the drain or something is goofed with it. I have found that if I pull CAN out of the module the un-wanted draw will go away in about 4 Min

1 Can you tell me exactly how to remove this module? I am too old to get under the seat more then twice a day it takes too much Advil.

2 Is the passenger seat adjustment controller the same? PNs are different but can controllers be swapped? If so I plan to swap parts to see if it is the controller or a network issue? Will the drivers side controller react in the passenger position from the drivers hand control? I can prove the issue if this can be done. If not I will just figure out how to analyze it some other way.

3 Is there any concern about driving this car with the f34 fuse pulled? I am afraid it could supply Volt source to other points then just this seat.

4 Any other ideas could help?
Thanks in advance for any help or smart cracks given, Bruce

Last edited by brujan; 12-25-2013 at 09:14 AM. Reason: new information discovered (up date)
brujan is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-25-2013, 09:34 AM
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 18,830
Mentioned: 18 Post(s)
Quoted: 884 Post(s)
Lifetime Premium Member
Welcome to the forums.

I would post this question in the W211 forums we have here.

W211 E-Class - Mercedes-Benz Forum
Noodles is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome