little help please - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-17-2013, 06:20 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2008
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
little help please

Just want a little help on what my problem might be and how much it MAY cost.
just bought a 2000 s500 , loved the Designo interior and had to have it , after about a month I had the Airmatic , stop car is too low come up , I started to notice that the passenger side front sat very low when parked , when I started the car up it raised , when I would drive the " Airmatic stop car too low " would come on and off , there where times it would not come on at all , and times it would come on and off, but every time the car was parked it would get very low on the Passenger side front, and sometimes on the driver side, I was told that the pump was replaced last year , the other day I drove the car and the red airmatic car too low came on and DID NOT go off, the car was soo low that the tires hit the wheel well when turning , can anyone give me any ideas on what it could be and how much this may cost , I am about to take it to get fixed ,what is the best case and would would be the worst ????? and I read many different things it could be , shocks , struts , strut leaks, pump , bad valve blocks etc etc
jubie is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-17-2013, 08:00 AM
Moderator
 
Ex-Fed's Avatar
 
Date registered: May 2013
Vehicle: 2006 S 500
Location: near Dallas, Tx
Posts: 1,075
Mentioned: 10 Post(s)
Quoted: 126 Post(s)
Lifetime Premium Member
Garage
From reading of others problems and using the W220 Encyclopedia..My guess would be:

Worst case.... Leaky strut has burned up the new pump trying to keep the system inflated.

Best case.. only one strut leaky.

A really good idea to solve the problematic airmatic system is >> https://www.arnottindustries.com/par...rts_yid18.html

will probably save you $$$$ in the long run
Ex-Fed is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome