2001 S class S320 diesel wont crank - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-29-2013, 12:08 PM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2013
Vehicle: s class 320
Location: Kent
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2001 S class S320 diesel wont crank

Hello, I have a 2001 S class S320 diesel, has been sat for around a year, now wont crank, all drove fine prior to standing.


Fitted new battery, fuel level 1/4, remote opens/closes doors and arms/disarms alarm fine, turn key but wont crank.


All electrics on car work and don't dim when go to cranking position on key.


Initially, car started, moved 10meters to blow tyres up while ticking over cut out and now has the none start symptoms.


Have tried starting in park and neutral positions and wiggling gear selector but no joy.


Brake lights work and releases from park when press pedal so assuming stop light switch isn't the fault.


On speedo display shows 0 malfunctions.


Im a little stuck now where to go, if anyone has any ideas all be greatly appreciated.


Thank you!
scottydouk is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-29-2013, 05:40 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,766
Mentioned: 9 Post(s)
Quoted: 1122 Post(s)
Please give us more info?
Where is Kent?
I have not hear about 320 diesel from 2001. but we are pretty limited with car supplies here in USA and even less in California, so not hearing about available models is nothing new.
2001 cars are digitally controlled, so when the battery runs low, the computer will not activate the starter. This is the symptom you have right now, don't you?
Welcome to the forum.
Kajtek1 is online now  
post #3 of 6 (permalink) Old 12-10-2013, 02:58 PM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2013
Vehicle: s class 320
Location: Kent
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you for the response.

Its a 3.2 turbo diesel S class.

Kent is in the united kingdom.

The battery is in a fully charged condtion.

Have checked fault codes with a snapon scanner, talks to all modules, ecm, abs, suspension etc, main codes in engine control module are glow plug faults, but im sure this wont cause these problems.


Have checked starter motor wiring, and have no cranking signal to the small two pin electrical connector, main battery supply is good and good ground to engine block.


Have checked all blade fuses on car and main power supply fuses in off side of boot compartment all ok.


Cant see any water ingress in the car or over any of the modules in the engine bay.


Is there any relays which could cause the fault I have?


Where to go next...........


Cheers
scottydouk is offline  
post #4 of 6 (permalink) Old 12-11-2013, 01:18 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
I believe this discussion would belong to the W220 forum but my advice would be to get hold of the starter motor related wiring diagram. Then you can measure if you have the start signal at the starter relay output (you said no signal at the starter motor solenoid), starter relay input etc.

I understand the key turns in the ignition slot but the engine does not crank. It should not be a key issue then. Can still be EIS, engine ECU etc. A good diagnosis with Star would be in place if it turns out to be no signal from ECU to the starter relay.
Diesel Benz is offline  
post #5 of 6 (permalink) Old 12-11-2013, 09:32 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,766
Mentioned: 9 Post(s)
Quoted: 1122 Post(s)
That topic belongs to diesel section
00ps WE DO NOT HAVE ONE
3.2 turbo diesel is the engine I did not hear about at all. Definitely not imported to US, where most of the members here reside.
I would try on UK forum.
Yes - they do have diesel section
Kajtek1 is online now  
post #6 of 6 (permalink) Old 12-11-2013, 05:52 PM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2013
Vehicle: s class 320
Location: Kent
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
which is the starter relay?
Cheers
scottydouk is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome