2012 GL550 Passenger HID Lights Not Working - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 10-18-2013, 11:50 AM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2008
Vehicle: 2005 CLK 320 ;2012 GL550
Location: PA
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2012 GL550 Passenger HID Lights Not Working

Hi everybody
Thank you taking the time to read through this .Recently I purchased a rebuilt 2012 GL550 ,everything was fine till recently. I had a new right head light assembly installed and mentioned I had a 1 year warranty on parts

Fast forward into the future my right head light doesn't turn on. It was flickering a while ago but now it just doesn't turn on.

I took it to Kennan in Downtown,pa. They mentioned that I don't have warranty and I said that is fine but the part should have warranty as i purchased it separate. The sales rep came back and said that the warranty on the part is void . Isn't this ridiculous ? or are they shying away from honoring the warranty on the headlight ? I didn't mind paying for the diagonistic if it led to something other that the defective headlight . or am i being un reasonable ?

So instead I took it to BBack carecare in Doylestown,pa they swapped bulbs between left and right and the problem stayed . He mentioned that there was no power for the light and suggested to take it to the dealer. I just don't like Kennan Dealership after their poor customer service .

Any suggestion as to how to proceed further?

I live in PA in buck county, would anybody recommend a Benz independent mechanic or is this a dealer kind of activity

Is there a DIY guide I can try , again I am a noob and any help would be appreciated


thanks in advance
The GL550 I eyed bandit
rascaly2k is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 10-19-2013, 03:19 PM
BenzWorld Member
 
Date registered: Apr 2009
Vehicle: 1999 E300TD
Location: PA
Posts: 167
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
where did you buy the light from and do you have proof?
saleen1276 is offline  
post #3 of 9 (permalink) Old 10-21-2013, 10:30 AM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2008
Vehicle: 2005 CLK 320 ;2012 GL550
Location: PA
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
It was purhcased in NY from Helms Bros. Mercedes-Benz - Bayside, NY and yes I do have proof of the receipt and the lies within the 1 year warranty period .I did call Helms Bros and they mentioned any Benz dealer should warranty the part .
rascaly2k is offline  
post #4 of 9 (permalink) Old 11-09-2013, 11:58 AM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2008
Vehicle: 2005 CLK 320 ;2012 GL550
Location: PA
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I have taken it to various dealers hear in PA, they mention that it might be the issue with the entire assembly and they mentioned the best recourse is to take it to the 3rd party place where I got it installed. I asked them about the warranty on the part and they side line the issue . All they mentioned is that if they need to dod teh work , they work charge diagnostics fees and any part needed they mentioned they would charge me again within the assemble
Any suggestions
rascaly2k is offline  
post #5 of 9 (permalink) Old 11-09-2013, 01:52 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,082
Mentioned: 18 Post(s)
Quoted: 927 Post(s)
Lifetime Premium Member
If you have to have HID then it sounds like your are stuck.

If you have the original hardware put it back in for now and see they can bench test the aftermarket parts so at least you can drive.

How long is the warranty on the aftermarket stuff?
Noodles is offline  
post #6 of 9 (permalink) Old 11-11-2013, 08:34 AM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2008
Vehicle: 2005 CLK 320 ;2012 GL550
Location: PA
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I had purchased the entire right xenon light assembly from the benz dealership in NY. So it was not an after market product. And the benz dealers mentioned that they have a 1 year warranty on part from the date of purchase . Now that the part is not working, i am getting the run a round from the dealers mentioning that the 3rd party who insatlled it is at fault . Again to me this is stupid reasoning as its implying I was just quite for a 10 months and now I decided to wake up with an issue. And they are side stepping the warranty of the part. To me this is riddiculous , but am not sure what my course of action ought to be done or is their a higher auhority I can take my case to ?
rascaly2k is offline  
post #7 of 9 (permalink) Old 11-11-2013, 12:56 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,082
Mentioned: 18 Post(s)
Quoted: 927 Post(s)
Lifetime Premium Member
It should be more clearly stated at the time of sale and on the invoice.

It is common practice for dealers to not want anything to do with electrical part returns unless the dealer installed it.

Why they are just not being honest about that policy is baffling. Have a friend call the parts dept and ask them if electrical parts are refundable after they have been installed by the owner or a third party regardless of the age of the part.
Noodles is offline  
post #8 of 9 (permalink) Old 11-17-2013, 05:13 AM
Lifetime Premium Member
 
Date registered: Oct 2012
Vehicle: 13 S550 4MATIC advantgarde edition, 2000 E55, 1982 500 SEC
Location: toronto
Posts: 225
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
Lifetime Premium Member
are there any fault codes?
BT ZR1 is offline  
post #9 of 9 (permalink) Old 11-18-2013, 03:05 AM
BenzWorld Newbie
 
Date registered: Nov 2013
Vehicle: BMW
Location: Pakistan
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have no idea.
Michaele97 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome