Problems with my 01 E430 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-30-2013, 05:02 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2013
Vehicle: 2001 Mercedes E430
Location: tampa, fl
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Problems with my 01 E430

I bought this car recently from an auction and I'm trying to fix some problems but I'm having a hard time pinpointing the issues. Here's a list:

1. My rear passenger window will not do anything. It was up when I bought it and it will not move. Initially I assumed it was the motor but after reading a lot of forums now I don't know if it's the motor or the regulator. When I press the button I hear nothing. I would think that if the motor still worked, I would hear something.

2. When taking apart the door to inspect the motor, the directions I was reading said to disconnect the battery to insure there wasn't a short that would cause the airbag to deploy in my face. After having the battery unhooked for about 45 mins I hooked it up and went in. The next morning when I started the car I had several things happen: the bas, abs, and esp alarms came on; the 3 windows that do work still work but when I press the buttons down all the way to make the auto roll up, they stop in place; I just had a door latch fixed because the dome light would not go off when I shut the door. Now again it stays on and at the same time the headlights do not flash 3 times anymore when I lock my doors. I'm not sure what is causing this but I hope its a simple fix.

3. My malfunction light alarm triggers randomly when I hit my brakes. I had the bulbs burn out once so I replaced them. They worked fine for a day then the alarm triggered again. After messing with it for a few hours I ended up switching bulbs and carriers from the left and right sides and it worked again. Now a few weeks later I am getting random light alarms after pressing my brakes. There in no consistency with the alarm.

I hope someone can help me diagnose these issues. I do not have another $150 for Mercedes to diagnose the problem so I would like to figure this out alone. Thank you ahead of time.
Ssparks is offline  
Sponsored Links
post #2 of 2 (permalink) Old 09-30-2013, 10:13 PM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,526
Mentioned: 9 Post(s)
Quoted: 1068 Post(s)
Welcome to the forum.
Your car is W210 body and we do have active section designated just for it.
You will find lot of info in stickies there about synchronizing windows, sunroof and ESP what will solve most of your issues.
Use only MB light bulbs. Other will trigger warning.
Kajtek1 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome