my new forum for my new benz - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-17-2013, 06:55 PM Thread Starter
BenzWorld Junior Member
Date registered: Sep 2013
Vehicle: 1997 s320
Location: florida
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Talking my new forum for my new benz

hi y'all. just bought my first mb, 1997 e320. for 2900. I got a dark green 4door, cream leather, nearly new tires, very few rusty spots and dings, radio works. drives nice, looks decent, sunroof goes up and down, what more could I want? 135000 miles, engine smooth, quiet, powerful 6. but the lights? abs, ets, srs all on. left front fender may have been replaced.... lights look new and frost-free, old and dingy on pass side. tinyest jitter when braking hard. oh ya, ac not cold. only cool.
I want the ac to work, hot in s. fla. don't know if I need be concerned about lites. this will be my Sunday feel good ride, happy if it works for a year, maybe only a few thousand miles? it's a really neat old gal. expect to enjoy what life is left.
glad to be here, thanks for list'nin- st
seekertom is offline  
Sponsored Links
post #2 of 3 (permalink) Old 09-17-2013, 08:36 PM
Lifetime Premium Member
jaymaynard's Avatar
Date registered: Mar 2013
Vehicle: 2008 ML320CDI 4Matic, 161K miles; 1983 380SL (die Rostlaube), 238K miles
Location: Fairmont, Minnesota, USA
Posts: 2,558
Mentioned: 2 Post(s)
Quoted: 381 Post(s)
Lifetime Premium Member

The ABS/SRS/ESP lights on is a common problem on W210s (the chassis type of your car, and mine).

Seek out the W210 forum, read through the stickies, ask questions.

Most of all, enjoy your ride!
jaymaynard is offline  
post #3 of 3 (permalink) Old 09-17-2013, 10:35 PM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,510
Mentioned: 9 Post(s)
Quoted: 1057 Post(s)
Do one thing at the time. ABS would be my priority.
Are all tires the same size/wear?
Go via pointed stickies in W210 section.
Kajtek1 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome