Help-Lost Spring On 300TD 1999 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-21-2013, 04:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2013
Vehicle: 300TD 1999
Location: Connecticut
Posts: 41
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Help-Lost Spring On 300TD 1999

First post on this site-was looking for some input or guidance with an odd occurrence.

I have a 1999 300 TD with 172,000 miles. Last week my front right spring came lose from the top cap and broke free while driving. Was barely able to drive home, not sure what had happened , but right side dropped where tire rim is almost touching tire. Brought it to a mechanic and he said the top cap of the spring rusted out and broke free from the spring. He said this cap is attached to tower ridge and I needed to get it fixed at a body shop since the rusted cap was attached to tire inside wheel cavity.

What should I do? Has anyone heard of this happening before. Should I get it fixed or just junk the car since he said the repair will be 2-3k and the alignment will never be the same.

Thank you in advance for your input. He said there was nothing I could have done to prevent this-very odd thing!
Japanese Maple is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-21-2013, 05:30 PM
Lifetime Premium Member
 
jaymaynard's Avatar
 
Date registered: Mar 2013
Vehicle: 2008 ML320CDI 4Matic, 161K miles; 1983 380SL (die Rostlaube), 238K miles
Location: Fairmont, Minnesota, USA
Posts: 2,559
Mentioned: 2 Post(s)
Quoted: 381 Post(s)
Lifetime Premium Member
Assunimg you're referring to the E300 Turbodiesel...

What you have is a well-known problem on the W210 chassis. Ask in the W210 forum for help on rusted front spring perches.
jaymaynard is offline  
post #3 of 3 (permalink) Old 08-21-2013, 05:36 PM
BenzWorld Senior Member
 
Date registered: Dec 2009
Vehicle: 1997 E300D
Location: Newport News , VA
Posts: 438
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
The rusted out spring perch is quite a common problem in rear wheel drive E class cars of your vintage. Go to the E class forum here and search for "spring perch". You will see that US body shops charge around $900 to fix one. Some folks have gone to their Mercedes dealer and had Mercedes split the cost of repair, but this may depend on their relationship with the dealer. Since I don't know where you are, Canada has a recall on the problem. As Mercedes repairs go, this is not very expensive, and not one that would cause me to get rid of a good car.
nelbur is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome