P0700 code - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-27-2013, 07:39 PM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2013
Vehicle: 1998 E320 W
Location: Manassas VA
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
P0700 code

My 1998 E320 just started to have transmission issues. I noticed it not shifting properly when I came to a stop light. When I tried to go on the green the engine raced as though it was in neutral and then it started to grab a little for forward momentum but it didn't shift properly. It was at that time that the check engine light came on along with Engine Electronics in the read out area. The yellow triangle light was flashing at that time as well. I limped home and each time I came to a stop light I had to turn off the car and let it set for about 10 seconds and then restart and it would go up to around 40 mph and the yellow triangle would flash and the engine would slow down. At last I had a friend come over to the house with his little code machine and we got the P0700 code. Here's the question, is this something I can do myself,(I'm pretty handy) or does it need to be taken to a good shop? Any past experience with this kind of problem? I await the vast knowledge and experience of you gurus. Thank you.
GarthsMB is offline  
Sponsored Links
post #2 of 2 (permalink) Old 06-28-2013, 05:39 AM
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 18,807
Mentioned: 18 Post(s)
Quoted: 876 Post(s)
Lifetime Premium Member
P0700 is a fairly generic trans code. A more advanced scanner would have shown more detailed codes. Unless you have has experience with repairing the 722.6 transmissions I advise to get the codes fully read and then you will know what you are facing. It could be a bad solenoid or conductor plate.
The trans my have worn out a clutch pack. If you look in the W210 section on the forums here there is a whole sticky thread about the transmission.
Noodles is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome