I NEED HELP! Originally Popped Code P0410 and P0700 Then after repairs P0410 & P0715 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 06-16-2013, 06:49 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question I NEED HELP! Originally Popped Code P0410 and P0700 Then after repairs P0410 & P0715

1999 Mercedes C280
Hello this site is great i dont know where to post this..... but I NEED HELP! I Originally Popped Code P0410 and P0700 when driving home from work a 35 minute drive had the car less than a week... The transmission started feeling like it was slipping its an auto trans. I new the battery was dead was having issues with it the closest place to go was Orileys Auto so I got a 124 dollar battery and put it in thinking the codes they read would go away after I replaced the battery. Kept slipping high rpms and only going 5-10 mph. After some research I decided to replace the conductor plate part #400488476708 Interchangeable Number #1402700561 (My OG Part Number)
I also purchased TCC/PWM SOLENOID 261161944362
AND
The 2 Black Line Pressure/Shift Solenoid for Mercedes Transmissions; 722.6 Part #221233347857 interchangeable with my part #1402770398 thinking that might be the problem from reading various articles. Installed all with the new 13 pin plug and put new fluid in.... Purchased an obd2 reader that can clear codes .... Ready to go!!!! Nope won't go out of first gear, runs great, shifts out of park, reverse neutral, but 1-D is all 1st gear .... Took it all back out, kept the new plate new plug and reinstalled the original solenoids. It still won't come out of 1st gear, its not in limp mode which is second gear from what I read. I don't know what the hell it is..... after repairs P0410 & P0715 are the codes that pop up... I suspect highly it's now the The TCM under the passenger floor or possibly the Shift Box & Gear Shift ECU unit.... but no signs of it being disrupted or broken or anything spilled on it ... I'm at a loss and on a budget right now I can't afford a dealer and don't know what to do... I need advise badly! I think I know how to fix the 410 code not too worried about that thats an emissions code.... I'm concerned with my car not shifting out of first I need it for a computer car badly and am hemorrhaging $$$ driving my lifted Tahoe with 35's and a 350 in it 35-45 mins each way to work. I really think it's the TRANSMISSION CONTROL SHIFTER MODULE ECU Part# A0245458132 EGS51 or Shifter Assembly Part #: 202 267 01 37 but this seems not very logical and doesn't look like anything was spilt on it.... Leaning towards the gear selector TCM.... That resides under the passenger foot rest.... Please help any opinions would be greatly appreciated! Please I need advise and Help!
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	572
Size:	32.0 KB
ID:	521801  
Icucme4 is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 06-16-2013, 06:53 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question

My phone only let's me add one pic at a time
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	619
Size:	34.6 KB
ID:	521802  
Icucme4 is offline  
post #3 of 19 (permalink) Old 06-16-2013, 06:55 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
My Phone only let's attach one pic at a time!
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	689
Size:	28.8 KB
ID:	521803  
Icucme4 is offline  
post #4 of 19 (permalink) Old 06-16-2013, 06:57 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
This is what I think I might need to replace....

My Phone only let's attach one pic at a time!
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	734
Size:	55.2 KB
ID:	521804  
Icucme4 is offline  
post #5 of 19 (permalink) Old 06-16-2013, 07:09 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Or maybe I need this? But it goes to P-R-N-D
1-D is all the same it's stuck in first drives normal just wont shift... ????
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	851
Size:	38.7 KB
ID:	521805  
Icucme4 is offline  
post #6 of 19 (permalink) Old 06-16-2013, 10:44 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,082
Mentioned: 18 Post(s)
Quoted: 929 Post(s)
Lifetime Premium Member
Once new parts are installed the codes have to be cleared from the Transmission control module and the ECU memory in that order or the problem will persist even if the parts fixed the problem.
A pro grade shop scan toll or a MB Star Diagnosis system will be needed to clear the codes in both places.
Noodles is offline  
post #7 of 19 (permalink) Old 06-16-2013, 11:17 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I cleared the codes via an obd2 tool I purchased do I need a more in depth one ? I will take it in and have them cleared.../scanned but once I cleared with my tool old problems stopped new problems began - new at all this Mercedes stuff I have a 1964 Dodge 880 Custom in the driveway I'm getting a crash course in new cars.... Lol I will go to a shop if my reader/clearer program isn't good enough it says clearing the memory and error codes on the computers and check engine light goes off for a while then come back on but car still won't shift
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	243
Size:	22.4 KB
ID:	521862  
Icucme4 is offline  
post #8 of 19 (permalink) Old 06-16-2013, 11:22 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I use a program called Torque via my phone or tablet
Icucme4 is offline  
post #9 of 19 (permalink) Old 06-17-2013, 12:05 AM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,082
Mentioned: 18 Post(s)
Quoted: 929 Post(s)
Lifetime Premium Member
That is fine for basic ODB II stuff, but the transmission codes and its control unit need a device that can handle the MB proprietary protocols.
Torque via an Android device is handy, but far from a pro grade shop scan tool which is what you need to clear the transmission codes from the control unit and ECU.
Noodles is offline  
post #10 of 19 (permalink) Old 06-17-2013, 12:10 AM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I will get them checked tomorrow and report back - thank you
Icucme4 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome