1997 Mercedes Benz E320 overheating problem........please help! - Page 4 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #31 of 42 (permalink) Old 07-28-2013, 01:44 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,191
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Quote:
Originally Posted by Kajtek1 View Post
Playing Sherlock Holmes here putting the facts together >>> new clutch runs the fan at high output (judging from the noise) yet the engine overheats after the installation.
Do you have the blades reversed?
The engine overheated before the installation also.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links
Advertisement
 
post #32 of 42 (permalink) Old 07-28-2013, 02:12 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2010
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Yes, I mean the large engine belt
akusbharat is offline  
post #33 of 42 (permalink) Old 08-09-2013, 10:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2010
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello Guys,
As I said earlier, I have shown the car to the radiator shop.
He did a basic check of thermostat and radiator. When I explained my problem, that the car overheats in 20mins after driving and is okay when I am driving on the freeways and also when I accelerate the car to higher rpm's, the heat gauge comes down.

His explanation was
" If a radiator is clogged, it will always be overheated and no matter what, the temp wont come down" " He checked thermostat with a electric gun which shows temp, he said it is fine"
Then comes his recommendation.
"I am not sure about this cars but I think it is the problem with water pump, as I said when I accelerate the car, the temperature goes down because of excess circulation while increasing rpm, which would bring down the temperature" He recommended couple of mechanics who work on only this cars, and said they would better know than himself.

But, before consulting other mechanics, I want to take your opinion on this problem, and whatever the radiator shop guy thinks makes sense.
Also, please let me know how much I am looking at to replace or repair a water pump.

Thanks again folks, awaiting for your response.
akusbharat is offline  
post #34 of 42 (permalink) Old 08-09-2013, 10:17 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2010
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by eric242340 View Post
If the hoses are not the same temperature then either the radiator is blocked or the thermostat is not opening fully. Take the thermostat out and try the car without it.

You need to fix the overheating problem before dealing with the noise, the noise may actually be the two aux fans running on full wack trying to cool the radiator down.
Hello eric242340,

Making my correction from above post, that both the hoses coming from thermostat are super hot, cannot even touch for a second.
akusbharat is offline  
post #35 of 42 (permalink) Old 08-10-2013, 03:05 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,191
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Quote:
Originally Posted by akusbharat View Post
Hello eric242340,

Making my correction from above post, that both the hoses coming from thermostat are super hot, cannot even touch for a second.
In that case it is not the thermostat and not the radiator.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #36 of 42 (permalink) Old 08-19-2013, 06:04 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2010
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello All,
Can you please respond back if you think the problem I have is a water pump issue.

FYI, I havent turned on AC for quite a while now, will this make water pump die, but AC turns on fine blowing cold air

Last edited by akusbharat; 08-19-2013 at 06:10 PM.
akusbharat is offline  
post #37 of 42 (permalink) Old 09-19-2013, 01:56 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2010
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello All,
Can you respond me back, what the car problem could be.
Do you think is it because of water pump?

I havent fixed my car until now and not going to far in this car,
akusbharat is offline  
post #38 of 42 (permalink) Old 09-19-2013, 04:38 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,191
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Quote:
Originally Posted by akusbharat View Post
Hello All,
Can you respond me back, what the car problem could be.
Do you think is it because of water pump?

I havent fixed my car until now and not going to far in this car,
I think the next step would be to remove and inspect the water pump, the impeller may have broken off, but the only way to check is to remove the pump.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #39 of 42 (permalink) Old 09-19-2013, 09:26 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,789
Mentioned: 9 Post(s)
Quoted: 1127 Post(s)
On my diesel I was able to stick finger into thermostat hole and feel broken impeller before pump removal.
The theory doesn't quite confirm - broken impeller would never cool the engine and the hoses would not get hot on both sides.
Kajtek1 is offline  
post #40 of 42 (permalink) Old 09-19-2013, 12:16 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2010
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Kajtek1 View Post
On my diesel I was able to stick finger into thermostat hole and feel broken impeller before pump removal.
The theory doesn't quite confirm - broken impeller would never cool the engine and the hoses would not get hot on both sides.

I understand your point, what can make the engine cool when I accelerate(higher rpm) the car.
A mechanic told, when you accelerate, it is pushing water from water pump, so check your water pump, which sounded me right, but wanted to take all your suggestions here before even trying to fix it
akusbharat is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome