99 ML430 stats poorly sputters and stalls. - Page 2 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #11 of 12 (permalink) Old 07-19-2013, 01:44 PM Thread Starter
BenzWorld Junior Member
emerson69's Avatar
Date registered: Dec 2012
Vehicle: 1999 ML 430 77K
Location: Maui Hawaii
Posts: 44
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
CP, Have not done the job yet. (And yes, it is silver..very funny) Had to order the pump and filter as well as new hoses because the new upgraded filter is longer and the old hoses wont fit. Figure right. I will keep you posted and please do the same if you fix yours. Cheers!
emerson69 is offline  
Sponsored Links
post #12 of 12 (permalink) Old 07-21-2013, 04:13 PM
BenzWorld Junior Member
Date registered: May 2010
Vehicle: 1999 ML430
Location: Irvine, CA
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
hi emerson,

so ended up repainting the car green and it seemed to have worked........ ok I took the joke one too far.

I did replace fuel pump and filter and it seems to have worked. i've driven about 50 miles and not one stall or hesitation. I just hit 168K so I guess it's about time for something like this to go. hope this fixes your problem too.
cphoenix is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome