W126 White Smoke - Page 3 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 21 (permalink) Old 06-26-2013, 10:06 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2012
Vehicle: 1970 Mercedes 220D
Location: California
Posts: 61
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
ok, changed the relay and the dash light turns on and then off. I start the engine quickly...not as much white smoke but it is there. The smoke lasts for about 15 seconds and then it goes to grey/black and none. The engine is a bit rough when cold started but seemed to smooth out. Could it be faulty or really dirty injectors?
My 220D is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome