95 SL320 doesn't change gears properly - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-03-2013, 10:28 AM Thread Starter
BenzWorld Newbie
Date registered: Jun 2012
Vehicle: 1995 SL320 (R129) and 2000 ML320
Location: North Carolina & Florida
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
95 SL320 doesn't change gears properly

I have a 1995 SL320 convertible that I have owned about 1 year. Among the multitude of problems that have cropped up the newest is this: When starting out it has to rev up to REALLY high rpms before it will shift out of first or second. I can avoid this by manually shifting the transmission from 1st to 2nd to 3rd. Any idea what is going on?
thisisjoey is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome