99 E-320 steering stiffness - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-03-2013, 09:39 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2013
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
99 E-320 steering stiffness

Recently my cert. MB mechanic added PS fluid and said that if this didn't solve the stiffness problem; then it might need a PS pump.So after a wek where the fluid was a bandaid, the stiffness has returned big time.After the car sits overnight or after an extended similar period of time, the SW is very stiff and loosens up after 5-10 miles. However, the hum is till there and the stiffness still there but not as bad and the car is still drives ok. What if any may be other causes?

Thank you.
millenend is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-03-2013, 09:52 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Due to the noise it might be the PS pump. That happened on my Toyota. But on still another car when I had similar symptoms (stiff steering) I had a bad rack and no noise. Are you still losing PS fluid?

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 4 (permalink) Old 06-03-2013, 10:02 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2013
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Musikmann

Yes
millenend is offline  
post #4 of 4 (permalink) Old 06-03-2013, 10:24 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
OK then first I would find the source of the leak. The PS pump can leak, so can the rack and the PS hoses can too. Been there and done that on 2 cars.

For my Toyota that had a leaking rack my tech told me to buy some PS fluid condition because it might lubricate (and swell) the seals and stop that. So far so good after a few months and a couple thousand miles. The odd thing on that car is we are supposed to use ATF as PS fluid but I chose to buy/add PS fluid conditioner.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome