2006 Ml 320 no start - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-02-2013, 08:26 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2013
Vehicle: 2006 ML320 Cdi
Location: Australia
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2006 Ml 320 no start

Hi all new to this forum would like to say you guys have been very helpful with quite a few issues I have had with my Ml.But I am becoming very disappointed with the product and the love affair is coming to and end I love driving my Ml when it is going.It is like a high maitianance women,please don't take of fence to this similarly.Now to my current problem,last my Ml was running I was driving home and the engine just cut out and the engine light came on.Tried to restart car it turned over but would not fire.It has been like this for three months now.Yes it is at a motor shop they have tested everything than can think of
There is no obious fault codes.Both fuel pumps have been tested and are ok.The crank angle sensor has been replaced,the front Sam has been replaced still no go.Please help at wits end
Thank you in advance Steve O
Steveo1965 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-02-2013, 09:56 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,171
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Several items could cause this but for best replies please cut n paste the above to a new thread in the following forum;

W164 M-Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome