Hey all - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-23-2013, 06:45 AM Thread Starter
BenzWorld Newbie
 
Date registered: Feb 2013
Vehicle: 1995 Mercedes S500 Coupe
Location: Pearl City, HI
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hey all

I joined a few months back but haven't gotten around to introducing myself due to personal reasons.

I'm 24-years-old.
2nd Generation Japanese-American living with my parents in Hawaii.
My dad gave me his 1995 S500 Coupe about a year ago (he wasn't driving it much).

I'm not going to lie.
Me being here is a grim outlook on my future dealings with this vehicle.

I love this car.
Not only because it's a Benz, but because of...everything else.
The seats, the way it runs, the powerful engine, even the old-fashioned look.
The sounds...my god the sounds are...orgasmic with the right music.
However, because it's a Benz is why I may need to fix it up and get rid of it (however much I don't want to).

I'm not all that rich (in fact I'm living paycheck to paycheck), and neither is my family.
When it comes to dealing with vehicles I can do the little things most car owners are supposed to know how to do.
However, when it comes to non-Japanese or non-American vehicles, my mind slips and I begin to panic.
Looking around this site helped me with that (I couldn't find where the Coolant tank was because the Manual didn't clearly show where it was).

And my tools are limited.
We have the basic tools to get by, but get beyond what our Ratchet kit has and it's like going on a fishing trip without extra lines and tackles.
My knowledge of cars are slim as well, even with the one's I'm most familiar with.


...sorry, I'm rambling.

The main problems I'm having are:
-Power Steering assist
*It's a work out to turn the steering wheel, if I turn it enough sometimes the Power Steering will kick in and make it easier (especially when turning to the right).
It's not the fluid, I checked that.
It may be another problem, but it's not the Power Steering as a whole since the wheel corrects itself after a turn, and (like I said) sometimes turning is easy, if I attempt to cock it.

-Air Conditioner
*This I can probably fix, we'll see. I'm pretty sure it's the blower. Even when it's on air won't come out.

-Middle Tail-Light
*This I can probably fix as well, however it's probably not the bulb (which sucks). Bulb likes to turn on and work once in a great while.

-Left yellow, blinker light thing
*Doesn't turn on with the headlights. Not a HUGE problem since it still works as the Blinker signal, so it's kinda at the bottom.

-Left Side Mirror
*Does not want to move up or down. Not a big problem, but something I'd like to deal with.

-Left Tail light
*Half of it doesn't turn on.
This is the bulb, I can do this...

-Minor Paint/rusting
*There's a spot on the roof next to the sunroof (right on the corner) that's rusting a little.
And the coating on my trunk is fading and slowly chipping off.
These I can deal with.

-Headlight Switch (Knob. Might be the switch too)
(This is actually what caused me to post this. I'm currently in my car, typing all of this out on my phone, trying to figure out how to get this to work so I can get to...work. It's 0345hrs, btw)
*For a while, this is the main problem of my existence with this vehicle.
Everything else I can work with.
The switch stopped working properly a few months back, at first the Fog Lights wouldn't turn on (no big deal, but it's not the bulbs. Like the middle tail light, they like to work once in a great while).

Then, it would turn on, by itself, in the middle of the night. Even killed my battery once (got a jump from my neighbor, haven't replaced the battery yet...anyone know where I can get one? Or is the one from Walmart okay?)
I had to tape the switch to one spot to get it to stop.

THEN the stopper things on the switch (the ones that stops the arrow on the different modes) began to get mixed up with the wirings.
I can have the switch cocked all the way to the right (passed the mode) and have the yellow lights, and dashboard display on when it's supposed to be regular headlight ON functions.

THEN (a few hours ago) the lights wouldn't turn on at all...

THEN (a couple hours ago) if I cock the switch all the way to the left, the headlights will turn on.
Nothing else.
Bring it back a little to the middle, headlights off - Display lights on.
Middle to right nothing.

NOW (because I keep playing with it)...it's....it's a mess.
I don't want to leave because I don't want the light to turn on by itself and leave me with a dead battery...
I need help.

If I can really fix this up and keep it maintained, I'd like to keep it.
If I can't then I need it decent enough to get something out of it.

Please...for the love of god...I need help...
Thanks for reading.
Hope I get to stick around for years to come...

Last edited by Delta8O8; 05-23-2013 at 07:50 AM.
Delta8O8 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-23-2013, 10:04 AM
BenzWorld Member
 
rudy1's Avatar
 
Date registered: May 2013
Vehicle: Strait Jacket
Location: Crazy Town, USA
Posts: 128
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Super helpful folks here...You've come to the right place
Post Regularly - Share What You Learn - Live Long and Prosper
rudy1 is offline  
post #3 of 4 (permalink) Old 06-02-2013, 08:40 PM Thread Starter
BenzWorld Newbie
 
Date registered: Feb 2013
Vehicle: 1995 Mercedes S500 Coupe
Location: Pearl City, HI
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the welcome!
Delta8O8 is offline  
 
post #4 of 4 (permalink) Old 06-02-2013, 09:03 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,604
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Welcome to Benzworld.

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome