1999 ML320 P0141, P0161 and P0400 CEL codes - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-18-2013, 10:15 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2013
Vehicle: 1999 ML320
Location: New York, NY
Posts: 6
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Post 1999 ML320 P0141, P0161 and P0400 CEL codes

Hello all!!! I went to my local Autozone to get printout for all the codes on my ML320. She yielded 6 codes in total. A couple for misfired cylinders and 4 for my o2 sensors. I changed all plugs, wires and a couple of ignition coils on the first day and changed all 4 o2 sensors on the next. I cleared the codes, drove for a bit then the light returned. This time I get P0141, P0161 and P0400. Any ideas on how to get these cleared for my inspection and registration renewal?

Fuse 19 in fuse box is functioning, o2 sensors just changed, egr valve hose cleaned and egr changed. Any help would be greatly appreciated. Thanks in advance!!! -Ngine
Che cke Ngine is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-18-2013, 09:10 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,595
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Asking questions on your model

Firstly welcome to Benzworld, for best results ask your question on the specific forum for your model and that is;

W163 M-Class - Benzworld.org - Mercedes-Benz Discussion Forum

Before doing this use the search function as this subject and these codes have been discussed many times and there will be lots of answers.

Lastly you may find it is a bad MAF sensor or a small vacuum leak.
Attached Thumbnails
Click image for larger version

Name:	Snap1.jpg
Views:	302
Size:	29.1 KB
ID:	510089  
Attached Images
 

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #3 of 4 (permalink) Old 04-19-2013, 06:51 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2013
Vehicle: 1999 ML320
Location: New York, NY
Posts: 6
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
I have actually taken a close look through many topics in many forums. I was told that the blue wire leading to the o2 sensor isn't receiving any current. Any suggestions on what to do now? And about the egr, I will be removing the valve cover to clean out the carbon deposits today. Even with those codes not being related to the MAF sensor, could that still be the issue?
Che cke Ngine is offline  
 
post #4 of 4 (permalink) Old 04-19-2013, 07:00 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,595
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Quote:
Originally Posted by Che cke Ngine View Post
I have actually taken a close look through many topics in many forums. I was told that the blue wire leading to the o2 sensor isn't receiving any current. Any suggestions on what to do now? And about the egr, I will be removing the valve cover to clean out the carbon deposits today. Even with those codes not being related to the MAF sensor, could that still be the issue?
I would prefer you started a new thread on the appropriate forum as there are members on that forum who are techs just like me and understand your particular model better, but yes the MAF sensor is always a prime suspect.

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome