Mercedes Benz W202 near stalling when stopping or accelerator lift - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-17-2013, 07:33 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2013
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Mercedes Benz W202 near stalling when stopping or accelerator lift

Hi hopefully this is a valid new thread as I cant find any that are a close enough match for my issue.

Car is a 1995 W202 C220 with what I believe is the M111 engine (could be wrong)

Symptoms are simply when I press on the gas and release, the revs drop well below normal and engine nearly stalls but doesn't, also similarly when driving whenever I get to a stop sign or traffic lights and have to stop the same issue occurs the car nearly stalls. No CEL is on.

Checked and tested and disconnected MAF so not the cause as it causes further erratic engine behaviour when not connected

Disconnected Cam position sensor does seem cause further erratic engine behaviour

Another possibly related symptom is the Fuel pump does not shut off while key is on prior to starting, it also sounds like bubbles going through a hose pipe.

My guess and I'm hoping someone can confirm is that either the input pipe to the pump has a leak (no fuel is visibly leaking) and is sucking air through (also in so doing preventing the pump to reach proper pressure for shut off and or idling)

or the pump is worn out causing a lack in pressure (wouldn't explain bubbles though right?)

or clogged Filter (wouldn't explain bubbles or failure to reach pressure and subsequently shutting the pump off)

or faulty pressure regulator valve / sensor (not 100% sure if these cars have them but BMW for eg do and its common enough for them to go bad) if its just a sensor then unsure how that would affect fuel pressure but probably badly if it is stuck at a running pressure instead of idling pressure?

I have been driving the car like this for almost 4 years and behaves fine as long as when I come to a stop I keep the revs up.
si98justme is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome