Help needed to get my 2001 clk convertible started - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-15-2013, 01:52 PM Thread Starter
BenzWorld Junior Member
Date registered: Apr 2013
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Help needed to get my 2001 clk convertible started

So heres the story bit by bit, hoping some of you very smart Mercedes Benz Gurus can help me get the 2001 430 clk started. If you could even answer some of the questions it would be greatly appreciated.
I bought this wrecked 2001 430 clk convertible with 80k miles on it , Other than the front end damage it’s a pristine car. Serviced regularly ,and easily driven,and it’s a beautiful car.
I replaced the front frame clip, fenders, hood , radiators, fans, waterpump, lights, and everything needed to get it back on the road, still need some parts but hey.. it’s a project . its to a point I need to start it up and service the motor and do other things.
I charged the battery, reset the computer, and most things work(windows, locks,trunk, lights,)
The convertible top doesn’t go down tho,
and the starter wont engage
Im sure it will run but I’m Bummed now,
The questions I have now are this,
The Key, It’s the right key because the locks unlock, trunk works, sterring unlocks when its put in the ignition, lights on dash comes on and looks like its ready to start. Seems like the brake switch may not be working(push brake to start)??? Wheres the switch and can it be bypassed for a test???
Trans needs to be in park…Wheres the switch and can it be disabled to test??? Bad switch??
The roll bars are up I think, I read somewhere they need to be reset ,switch on dash wont do anything, With the rollbars being up, will it stop the starter from engaging?? Is there a way to manually reset the rollbars??
Starter relay fuses??? Read something it could be #51, 54, 44 …cant find them to look(looked left of steering wheel, trunk, and under hood),no fuses of that #, and wheres the relay??
I still need the fan shroud ,so I havn’t filled the car with fluid,(water in the raditor only) Can there maybe a censer telling the computer theres no water in it, and not let the starter engage .
Could it be the starter selinoid???
I have pulled out my hair on this one,Im tired, frustrated, puzzled and disappointed in this project now and need some help, Can anyone help????
Thanks Dan
dan84v is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome