Eberspächer problems - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-08-2013, 10:56 AM Thread Starter
BenzWorld Newbie
Date registered: Apr 2013
Vehicle: MB 200C 2007
Location: Finland
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Eberspächer problems

I have problems with the installation of a Eber B5WS into a 200C -2007. The heater heats the engine pretty fast but do not let the heat into the car. Even when the heater has been working for more than an hour the temperature inside the car may still be only a few degrees when it is only -5C degrees outside. sometimes the ventilation system blows even cold air into the car even though the engine may be at +80C.
I have contacted Mercedes and according to them this is not normal. I have contacted Eberspächer and according to them this is not normal either.
According to the company importing Ebers to Finland this is nomal for Mercedes. The same opinion has the company that has installed the heater.
I have had heaters in several cars before but none with this problem. That's why I bought the heater, to have it warm in the car when it is cold outside.
Has anyone experienced the same problem? Is there any cure? Is this a feature for Mercedes/Eberspächer?

HBL is offline  
Sponsored Links
post #2 of 2 (permalink) Old 04-08-2013, 07:23 PM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,067
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Never heard of this equipment before so cannot help but welcome to Benzworld.


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome