C220 cdi no crank - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-26-2013, 08:39 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2013
Location: Queniborough,Leicestershire,england
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy C220 cdi no crank

Hi,I have a 2003 220cdi coupe that won't crank,I've read on the forum about it could be low battery,I've just fitted a brand new battery and still no crank,dashboard lights up with no problems glow plug light goes out but engine will not crank over,I've tried the spare key but still the same it moves from park when the ignition is on and I've checked all 3 points on the car for broken fuse's,has anybody got any idea of what the problem could be.
Regards John
savage_996 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-27-2013, 01:56 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,171
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld, it may be the EIS (Electronic Ignition Switch) use a hair dryer to warm the area around the switch and see if this works, I believe it is rather cold in UK at the moment and the EIS can be affected at low temps.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #3 of 3 (permalink) Old 03-27-2013, 09:11 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2013
Location: Queniborough,Leicestershire,england
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hi and thank you to those that replied,had the auto electrician out today and the car is now working,turned out to be a stuck solenoid on the starter.car now back to starting as it should.
Regards John
savage_996 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome