97 S320 Oil in Radiator but ... - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-24-2013, 09:34 AM Thread Starter
BenzWorld Junior Member
Date registered: Nov 2010
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
97 S320 Oil in Radiator but ...

Not in the oil Pan.


1997 S320 with Oil in the radiator and cooling system. normally would suspect a head gasket problem but there is no water in the Oil pan.

I did replace the water pump about 4 months ago.

Has anyone seen this? Not opposed to replacing head gasket but want to see if anyone:

1.) had a similiar experience
2.) had an alternative causes.

Oh, if somone has the procedure replacing the head gasket, I would appreciate a link...

Many Thanks
jfarmer64 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome