VITO HEATER PROBLEM! HELP PLEASE! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-13-2013, 04:04 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2013
Posts: 28
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
VITO HEATER PROBLEM! HELP PLEASE!

Hi guys,

It seems that this has happen before me. I've found this topic on another forum but had no replies to his help request.


"Hi, I've been lurking on here for a while & finding info to help my hubby with his Vito 108 cdi (2003) and up until now I've always been able to find the help he needed ... until now, so here I am

Last week his vito started cutting out when he was hitting 70mph on the motorway, in heavy rain, and the car heater was only blowing out cold air ... after looking on here, one suggestion for the engine cutting out was the fuel filter ... he changed it & while he was under the bonnet, he flushed the radiator. Now the car is running fine except for the heater ... its still blowing cold air. He's checked the following:

1. fuses
2. the wiring that he can get to behind the heater controls on the dash
3. the heater matrix isn't blocked, but the pipes are both cold
4. bled the water system

I apologise for my lack of vehicle knowledge/terminology in this post

He's away for the next few days, so won't be able to try out any suggestions, but I can still post any extra info from him, if its needed

Laura


fantomman"


(now Me...)

Hi,

I_ just got those same symptoms on my 111 2.2 CDI Vito, January 2010.

Have you solved it? How?

Engine is ok, never had any problem, no runing hot nor too cold. Air is blowing alright but no hot air. Fuses seem to be ok. Coolant level is topped always and has never been renewd. Problem started all the suden with no apparent reason. No warning lights on the dash.

Please help,

Regards and many thanks in advance,

TMonteiro


Please help!
TMonteiro is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome