722.9 Is replacement the only option to fix "ETC/VGS control unit defective"? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-05-2013, 02:52 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
722.9 Is replacement the only option to fix "ETC/VGS control unit defective"?

I'm learning how to use DAS and am wondering if I can flash the ETC and where I would get the code to flash it with and if it's even worth the trouble. It's the original version EHS A 220 270 14 06.

Also, the event memory says that no message was received from the central gateway control unit N93. Could that mean that there's a fault in the connection between the two? I think that would mean that the message is on the low CAN bus. Am I close?

I've done the power supply test at the ETC socket on the trans and it's got juice.

Being a motorhead is certainly not as easy as it used to be.

Schaeffer
Schaeffer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-05-2013, 02:56 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,088
Mentioned: 18 Post(s)
Quoted: 930 Post(s)
Lifetime Premium Member
Not sure what version of Xentry/DAS you are running.

Also if you on a VM version of it I strongly advise not writing any code to a control unit if a USB to serial adapter is in use. One timing hiccup by a nanosecond and your ETC would become a paperweight.
Noodles is offline  
post #3 of 5 (permalink) Old 03-06-2013, 06:22 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I have the 09/12 version for C3 DAS. And I'm using a Dell D430 with a RS232 port in the docking station so no adapter.

For sure I have a steep learning curve here and am trying to go slowly, but in the meantime, my car is not usable.

Schaeffer
Schaeffer is offline  
post #4 of 5 (permalink) Old 03-06-2013, 06:38 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The other thing is I suppose I shouldn't mess with the old unit and save it to use to transfer the data to the new unit. Or does the new embedded code replace the old completely?
Schaeffer is offline  
post #5 of 5 (permalink) Old 03-06-2013, 06:29 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,088
Mentioned: 18 Post(s)
Quoted: 930 Post(s)
Lifetime Premium Member
I am nit sure. They call it an update, but it may just overwrite the whole thing.

What it won't do is change the data needed for it to be associated to your VIN and transmission number.

With a version Xentry that recent you may need a password to do SCN version coding for each module(in this case the ETC). Just one more thing MB and Terradyne have done to try and thwart clones.
Noodles is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome