'99 E320 P0410 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-09-2013, 01:00 PM Thread Starter
BenzWorld Junior Member
Date registered: Jan 2010
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
'99 E320 P0410

Did my homework & troubleshot the system. MIL was coming on after as little as 50 miles with a few engine-offs in between. P0410 comes up each time.

Here is what I found during my troubleshooting;

1) air pump is fine, blows strong at start-up
2) vacuum solenoid works fine, vacuum at both check-valves & both check-valves work fine
3) O2 sensor seems to be functioning as it should (watched it vary within limits on computer screen readout).
4) R&R'd both check-valves and both ports into the head were clogged with black crud.
5) picked out crud w/a small jewelers screwdriver then blew out resultant crumbly bits w/compressed air
6) passages are clean for the short length I can see but I have no idea how deep they go & how many twists & turns there are (is there a head cutaway pic somewhere?) so I do not know if the clogs continue deeper into the head (I suspect they do).
7) Reset the MIL & ran the car for over 50 miles then got it tested
8) it failed due to "readiness"
9) MIL came back on when I started up the car to leave the emissions shop.

So I have a few Q's.
1 - How far does this car need to run before the computer readiness toggle clears?
2 - If I spray throttle body cleaner or some other cleaner down the clogged ports, do I risk killing the CATs?
3 - Will spraying out the ports help or are they so twisty it would be an exercise in futility?
4 - If I do spray them out, should I do it with the engine off or running?
5 - Can I clear the ports with a long bushy wire implement such as a pipe cleaner? Or do they go too deep?

Thanks in advance...
bob k is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome