power steering whine - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-21-2013, 07:29 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2011
Vehicle: Ml320. 1999
Location: S
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
power steering whine

half a million or bust, need an opinion. lost power steering at an idle, there was none until you got up to about 1000 rpm, soooo i replaced the pump myself, solved that problem but it constantly whineing at low rpm when turning, or at idle turning, system bled repeatedly, no air left,, drove another 1000 miles , very small leak one drop over night at most turned out to be the cooling hose on the radiator loose,,, tightened, drove another thousand no change still whines.,,, H E L P,,, could it just be a bad pump? bought rebuilt off ebay for 99.00 so im thinking that i got what i paid for, but if there was a problem with the system i can only thing a whine has to be the pump,, any imput would be greatly appreciated, dont want the headache of putting on another pump time and expense if thats the wrong thing.. any help?? thanks Newvisionss oh yea,,, also replaced the resovoir and O ring with a decent factory replacement, no cheap, did the twenty turns with wheels off the ground, sucked out fluid and put in new, did this twice to make sure there was no sign of air,,,

--------------------------------------------------------------------------------
newvisionss is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-21-2013, 11:05 PM
~BANNED~
 
Date registered: Dec 2012
Posts: 56
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
I think it is a serious problem you should contact some professionals.
shofurlimo is offline  
post #3 of 3 (permalink) Old 01-22-2013, 03:57 AM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,064
Mentioned: 18 Post(s)
Quoted: 923 Post(s)
Lifetime Premium Member
He has already posted the same issue in the W163 forum. He should be able to get it sorted out.
Noodles is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome