locks on liftgate ml320 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-15-2013, 07:43 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2012
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post locks on liftgate ml320

There are two locks that control the back swing door(liftgate), correct?
One is in the middle of the door hidden and the other is right where it latches to the bottom of the frame.
It seems to me that the hidden one does not lock correctly because the manual latch does not move when I use the remote.
What kind of lock is that?
Thanks much.
HimlerP is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-15-2013, 11:19 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,970
Mentioned: 22 Post(s)
Quoted: 1117 Post(s)
Lifetime Premium Member
They are connected to the same lock actuator.

Is the hatch locking with the remote? If so the rod that connects the inner latch may have popped out of its holder on the mechanism.
Noodles is offline  
post #3 of 7 (permalink) Old 01-16-2013, 12:13 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2012
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I already checked the rod and that's OK. I can manually latch it (lock it) and once I unlock it it does work, it just does not lock from the remote. Once the weather gets worm I'll have to take it out of there.
Thanks.
HimlerP is offline  
 
post #4 of 7 (permalink) Old 01-16-2013, 01:08 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,970
Mentioned: 22 Post(s)
Quoted: 1117 Post(s)
Lifetime Premium Member
The only thing I can think of is that the plunger on the actuator has decided to fail which is a known issue on these trucks. When you get a chance to look at it check the plunger first.
Noodles is offline  
post #5 of 7 (permalink) Old 01-16-2013, 08:48 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2012
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
What do you mean by: ...the plunger on the actuator...? Do you think I can find a schematic of the components for the issue?
Thanks.
HimlerP is offline  
post #6 of 7 (permalink) Old 01-16-2013, 09:14 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,970
Mentioned: 22 Post(s)
Quoted: 1117 Post(s)
Lifetime Premium Member
Noodles is offline  
post #7 of 7 (permalink) Old 01-19-2013, 03:16 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2012
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you for the link. Yes, I found disengaged solenoid from the mechanics of the lock, now I have to figure out how it is installed and some of that is described at the link. Very greatfull for that.
HimlerP is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome