Help: Interior Light/Open Door Issue - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-12-2013, 02:05 PM Thread Starter
BenzWorld Junior Member
Date registered: Aug 2012
Vehicle: 1987 Mercedes Benz 300SDL, 250K miles
Location: Chicago
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Help: Interior Light/Open Door Issue

So, I went to start up my 1987 300 SDL today and although the glow plug seemed to light up, the car failed to start.

I thought maybe I left the lights on and the battery was dead, but that wasn't the case.

Anyways, after some investigation, I realized that the passenger door light on the driver's side was on, even when the car was off. It's the light below the ashtray/lighter. I checked all my lighting switches and that wasn't the issue.

I took the car in for an oil change two days before, and noticed when I got in the car and put the key in the ignition, I was getting the warning alarm that sounds when the lights are on or when a door is ajar.

I now think they might have messed something up while they were vacuuming out the back seats, and now the car thinks the side door is open, even though it's not, so the light never went out, and it drained the battery.

My question is how can I fix this issue? Can someone tell me where the door ajar sensor is on the passenger doors? Is this something I can fix myself?

It's my main car, so I need it fixed badly so I don't get stranded with a dead battery.

Thanks so much for any help/advice.
Chicago1987SDL is offline  
Sponsored Links
post #2 of 3 (permalink) Old 01-12-2013, 02:56 PM Thread Starter
BenzWorld Junior Member
Date registered: Aug 2012
Vehicle: 1987 Mercedes Benz 300SDL, 250K miles
Location: Chicago
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Follow up

I went and tried to investigate for a bit and found door ajar sensor (pretty easy).

I pushed the botton in and no surprise, the light did not go off. I pulled the button out and disconnected it, thinking if the wires were not connected, it would go off. No such luck.

I even tried switching it out with the sensor from another door and again no luck.

I was hoping I would find that the button just needed to be replaced, but now I'm at a loss again. Anyone have an idea of something else it could be?

Two of my other doors are missing the light and the housing for it completely, I also found. But when I push those buttons, the remaining light goes off, yet my rear exit light still stays on.

I'm thinking of just removing the light for now, and then trying to revisit the issue in the spring (I'm in Chicago and working outside) and just fix all the doors then.

If I did this, does the exit light pop out on its own, or does the door need to be opened up to get it out?

Chicago1987SDL is offline  
post #3 of 3 (permalink) Old 01-12-2013, 03:41 PM
BenzWorld Elite
Date registered: Jun 2011
Location: Illinois
Posts: 3,774
Mentioned: 0 Post(s)
Quoted: 81 Post(s)
Sorry all I can tell you is luckily the "puddle lights" pop out easily and the wiring is a simple connector that slides off. Good luck with getting it resolved. Also, when you do fix it, the light assemblies are only like $5 from autohausaz, at least they were not long ago.

Last edited by w126Sam; 01-12-2013 at 03:44 PM.
w126Sam is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome