2005 S430 SAM Unit - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-10-2013, 12:43 PM Thread Starter
BenzWorld Newbie
Date registered: Nov 2012
Vehicle: 2005 S430
Location: USA - Louisiana
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2005 S430 SAM Unit

I am getting plenty of warnings: front left turn signal, left rear turn signal, left marker, and wiper fluid. It sounds like I have a bad SAM unit that controls all of these. Does anyone have advice as to which SAM unit it could be and if so how to change it. If it is a mechanic job please dont hesitate to let me know.

Thanks, The Rooster
nolarooster is offline  
Sponsored Links
post #2 of 4 (permalink) Old 01-10-2013, 10:56 PM
BenzWorld Member
Date registered: Dec 2012
Vehicle: 87 560SL, 71 280SL euro, 74 VW Ghia, 78 280Z Black Pearl, 78 280Z, 04 Corolla, 07 Odyssey, 94 Prizm
Location: Texas
Posts: 109
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
you will need to take it to the dealer. SAM module stands for Signal and Actuation Module. It will require coding for your vehicle and therefore you would need specialized equipment. I don't think Joe's Down the Street Shop can do it unless they have a DAS for MB. maybe you can take it to your dealer and just get it diagnosed before replacing any part. You may have bulbs burned out since the front SAM modules control front lights and the rear SAM controls rear lights. Do some basic checks before diving into any conclusions. Cheers.
OzzyQ80 is offline  
post #3 of 4 (permalink) Old 01-10-2013, 11:30 PM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,072
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Throwing expensive parts at a Benz is not very smart. Have the fault codes read and post them here so we can help you.


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #4 of 4 (permalink) Old 01-11-2013, 06:32 AM Thread Starter
BenzWorld Newbie
Date registered: Nov 2012
Vehicle: 2005 S430
Location: USA - Louisiana
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the response. When the front left turn signal went out I switched the bulbs from the working passenger one to the driver side. Still no signal. Then I started to diagnose. I am going to the dealer and have the codes diagnosed. I will post them when I get them. Really appreciate your advice and help in advance. Rooster
nolarooster is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome