88' 300e won't start - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-08-2013, 10:22 AM Thread Starter
BenzWorld Newbie
Date registered: Apr 2010
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
88' 300e won't start

My 88' 300e won't start. It turns and tries to catch but won't turn over. Where should I start? I let my niece use the car( bad move I know) and now it's acting up. I looked under the hood and saw the power steering fluid cover is missing! I think she ran it with the fuel too low too . Car now needs brakes, rotors ball joints shocks! I guess she thought it was a truck! Should I fix it or move on. Engine and transmission were good when I let her use it. Car has 223k. Any suggestions?

Sent from my iPhone using AutoGuide.com Free App
jcdickson1 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome