Hello! New Benz Owner - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-31-2012, 05:58 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2012
Vehicle: 2003 S430
Location: Greenville, SC USA
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello! New Benz Owner

Hey All!

I am a first time Benz owner and need some direction. I was fortunate to be able to purchase an '03 S430 at auction a couple of weeks ago. I am both thrilled and overwhelmed at all the options in this car. Its completely more than I could have imagined walking away from an auto auction with! Purely a dream! Once the initial excitement wore off, I soon realized though that I have no clue how to operate the sound system and it has me completely confounded.

Let me start by telling you that I am a female and have never been much of an auto enthusiast, so I will beg your grace in responding to me. I'm sure there will be a more appropriate thread to find the information I am looking for and I trust you will point me in the right direction.

This is what I am experiencing and what I'm able to share with you about the stereo/navigation system, and what I am having trouble with:

The system is a Kenwood DNX5160. I do not know if this was factory installed or an after market installation as I have no Owner's Manual.

The issue is that when I purchased the vehicle, the Satellite Radio service had been disconnected/cancelled (I assume from the dealership that placed it for auction) and I have not as yet initiated new Satellite Radio service.

My first question is if Satellite Radio service is required in order to use the radio. (For those who may be laughing, I understand. I would laugh at me too if I knew what I was laughing at! ;P) which leads me to my second question.

If Satellite service is not required, then how to I reset the stations to those available in my area?

So far, I have been able to figure out that I can use the following options on this system: MP3, DVD, CD, Navigation system.

I also do not know what is required in order to operate the telephone system.

Unrelated to the stero/nav system, I am also experiencing periodic issues with the SRS system that can/have caused things like the turn signals, heat/air controls & wipers not to work. Is there an easy fix like a fuse or wiring problem or will my new baby need her first visit to the dealership?

Thank you in advance for all your help and I promise to not be too much of a pest!

Have a great day & Happy New Year!

Happy Go Lucky
HappyGoLucky is offline  
Sponsored Links
post #2 of 3 (permalink) Old 12-31-2012, 06:06 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2012
Vehicle: 2003 S430
Location: Greenville, SC USA
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Oops! Forgot to mention that really technical things usually result in a blank stare so I won't be offended if you dumb it down just a little for me.

Thanks again!

HappyGoLucky is offline  
post #3 of 3 (permalink) Old 01-01-2013, 01:31 AM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,065
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld, not too many members read the introductions on this part of the forum, therefore it would help you to start two new threads, just copy and paste your post here to new threads in the following forums;

W220 S-Class - Benzworld.org - Mercedes-Benz Discussion Forum
Audio & Telematics Forum - Benzworld.org - Mercedes-Benz Discussion Forum

Then head off to this link and download a copy of the owners manual in PDF;

Mercedes-Benz - Home of C, E, S, CLS, CL, SLK, SL, R, GLK, M, GL, G Class


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome