"Check Left License Plate Lamp" error - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-28-2012, 06:23 AM Thread Starter
BenzWorld Junior Member
Date registered: Sep 2012
Location: Toronto
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
"Check Left License Plate Lamp" error

I've got a c300 2008 and have been getting the "Check left license plate lamp" message for a couple weeks.

Turns out that even after replacing both lamps (even though they were both working fine) the error message above keeps popping up every now and then.

Surprisingly, even when lights are off if I look closely I can still see some light coming off that left plate lamp...

Has anyone experienced and found out how to fix this type of issue?

Thanks in advance.
carflip is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome