2003 ML350 cd player - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-21-2012, 01:49 PM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2012
Vehicle: 2003 ML 350
Location: Fort Worth, Texas
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2003 ML350 cd player

My main screen tells me no cd player installed when there is one and was working last week. Any ideas?
MLM Benz is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-21-2012, 07:42 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,086
Mentioned: 18 Post(s)
Quoted: 929 Post(s)
Lifetime Premium Member
are you speaking of the 6 disc changer or the slot in the MCS unit?
Noodles is offline  
post #3 of 6 (permalink) Old 12-21-2012, 09:21 PM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2012
Vehicle: 2003 ML 350
Location: Fort Worth, Texas
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I have the 6 cd changer that sits in the back right side.
MLM Benz is offline  
post #4 of 6 (permalink) Old 12-22-2012, 12:47 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,086
Mentioned: 18 Post(s)
Quoted: 929 Post(s)
Lifetime Premium Member
I have attempted to repair them. It is very rare to fix one as the parts are hard to get.

I replace them with used units from eBay or salvage yards. It takes 15-20 minutes to
swap it.

Do not forget to eject your magazine with CD's before removing the failed unit.
Noodles is offline  
post #5 of 6 (permalink) Old 12-22-2012, 01:04 PM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2012
Vehicle: 2003 ML 350
Location: Fort Worth, Texas
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Could there be some sort of reset issue? Like a reset button?
MLM Benz is offline  
post #6 of 6 (permalink) Old 12-22-2012, 01:44 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,086
Mentioned: 18 Post(s)
Quoted: 929 Post(s)
Lifetime Premium Member
Not that I am aware of.

Pulling the fuse would be the only thing I can think of. I do not have a fuse chart handy at the location I am at right now.
If you pull the fuse I am not sure it is on the same circuit as the head unit. If it is you will want to have your radio code handy.

As far as the fuse map/chart it should be on large sticker on the inside of the fuse tray cover under the hood.

I honestly believe you 6 disc changer has seen better days or I would not be leaning that way. I have never heard of a "reset" fixing the message your getting.
Noodles is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome