Typical delivery time for stuff from Autosky? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 12-12-2012, 05:54 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Typical delivery time for stuff from Autosky?

I ordered a diagnostic tool from Autosky six days ago and paid for it. My order is showing as unshipped and my email and attempts at their chat room have not been successful.

Anyone care to share their experiences with them?/

Thanks,
Schaeffer
Schaeffer is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 12-13-2012, 10:52 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
So far, not good

I shouldn't have ordered from Autosky? I thought I did my homework and searched through the forums before choosing them.

No email replies, no Skype reply, 2nd Skype contact not valid, Online chat says to try a different department, called two of the three numbers on their website. No joy. I get put on hold for the first number which disconnects after a minute or so and the other number just rings.

The website says by the way that they ship one day after the order is paid for.

Schaeffer
Schaeffer is offline  
post #3 of 8 (permalink) Old 12-13-2012, 01:20 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,088
Mentioned: 18 Post(s)
Quoted: 930 Post(s)
Lifetime Premium Member
Diesel Benz covered a lot of it the other thread.
However I did a forum wide search on the term "Autosky".
Only one member named Brett posted anything about them. So that being said it is hard
to know from one person how good a company will be. You did not do anything wrong, but
will you get a working SD Connect?
Even the companies that ship clones that don't have working wifi usually provide tracking info within 48 hours.
Noodles is offline  
post #4 of 8 (permalink) Old 12-17-2012, 06:47 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Who knows?

I've filed a dispute with PP and have gotten a response from the seller but so far no tracking number 10 days after ordering.

And yes I have low expectations whether it will work or not.


Schaeffer
Schaeffer is offline  
post #5 of 8 (permalink) Old 12-19-2012, 04:40 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Tracking number sent and tool on the way.
Schaeffer is offline  
post #6 of 8 (permalink) Old 12-26-2012, 05:47 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Got the SDS but there was no PCMCIA to RS232 adapter included. The seller offered to send me one if I paid the shipping but I had already ordered one online.

Now to figure out how to install and use it.

Schaeffer
Schaeffer is offline  
post #7 of 8 (permalink) Old 01-03-2013, 03:53 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The USB dongle required by the sw isn't recognized on 4 laptops and I closed the pp dispute when I got delivery. Since then no reply to my emails and I guess I'm SOL.
Schaeffer is offline  
post #8 of 8 (permalink) Old 02-01-2013, 06:19 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2012
Vehicle: 2006 CLS 500
Location: West of Boston, MA
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
replacement sw version?

Since my usb key doesn't work and I've given up ever getting any help or even so much as a response from anyone from obd2tool, I guess I'm stuck with buying the software again.

And of course, I don't know if the C3 mux is any good either yet.

Is there any requirement for a particular version of the sw to go with a C3 mux?

Thanks,
Schaeffer
Schaeffer is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome