1991 190E 2.6 - engine dies after releasing ignition key - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-11-2012, 06:05 AM Thread Starter
BenzWorld Member
Date registered: May 2012
Posts: 285
Mentioned: 0 Post(s)
Quoted: 27 Post(s)
(Thread Starter)
1991 190E 2.6 - engine dies after releasing ignition key

Hello all.

Last night, my benz traveled about 15 feet then the engine just died. I tried to start it again, it cranks and it seems it likes to start but when I let go the key, the engine dies. I have full tank of gas and no indication of any kind of faults or errors before this.

If I start the car and don't let go the key; eg, just keep it in the start position, the engine starts and don't die and I can even maitain rpm but of course I don't want to do that for too long.

So what gives? Is it the ignition key, starter relay, solenoid, starter?

Any suggestion is much appreciated.

javelin68 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 12-11-2012, 03:36 PM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
Bad ignition switch would be my guess.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #3 of 3 (permalink) Old 12-15-2012, 11:53 PM
Lifetime Premium Member
A&L's300SL's Avatar
Date registered: Apr 2006
Vehicle: 87 300SL "Roadster" 86 420SEL "Limo" 89 420SEL The "New" Limo 87 190E 2.6 fact bodykit
Location: Mornington Peninsula Vic Australia
Posts: 1,576
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Lifetime Premium Member
How long do you have to crank over the engine before it almost starts?

If it's a while [15sec] it sounds like what my 190E2.6 was doing about a month ago.

After stuffing around for a couple of days going over everything from the dizzy/rotor to OVp it turned out to be the coil.

Good luck


"That's the way I like it baby, I don't want to live forever"- Lemmy

A&L's300SL is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome