New member, 1997 S 500 starting problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-12-2012, 09:36 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2012
Vehicle: 1997 S 500
Location: NYC Manhattan
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New member, 1997 S 500 starting problem

Hello, my name is Greg Heinrichs of NY,NY and I recently came into possession of a 1997 S500 that had a bad fuel pump. I replaced the pump, fuel filter and battery, checked plugs for fouling, have spark and fuel at fuel rail in engine compartment and the car will not start. It sounds like it wants to kick over sometimes but won't. What can I troubleshoot next to determine the problem? Should I replace the crankshaft position sensor--I can get one for about $33.00. Any guidance is helpful. The car was running 3 weeks ago but stalled and the fuel pump was bad - it would not go on with power to it while cranking--new pump comes on.
1997s500 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-15-2012, 12:24 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,185
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld, it is not the CPS because you have spark and fuel, if a faulty CPS then no spark and no fuel.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #3 of 4 (permalink) Old 11-15-2012, 02:47 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2012
Vehicle: 1997 S 500
Location: NYC Manhattan
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by eric242340 View Post
Welcome to Benzworld, it is not the CPS because you have spark and fuel, if a faulty CPS then no spark and no fuel.
Thanks, I thought so and you and others have confirmed it. I have replaced the old out of gap spark plugs and the CAM position sensor--it came up on the OBD II fault code reader. It sounds like it wants to start at times but still does not. I am going to wipe off the maf, put some techron in the tank and maybe spray some starter fluid in the throttle body while cranking to see if it will kick over. I will also continue to check for spark and fuel at the rail and then possibly test the injectors. Any other suggestions are greatly appreciated.
1997s500 is offline  
post #4 of 4 (permalink) Old 11-15-2012, 06:22 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,185
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
You need 3 main items to fire, fuel/spark and compression. You have fuel and spark.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome