New MB owner in Washington - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-29-2012, 08:55 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2012
Vehicle: 1990 300e
Location: Washington State
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New MB owner in Washington

Hi all, I just purchased my first Benz last night for $2700. It's a 1990 300e with 36k miles. I wasn't even looking at Mercedes as I never thought I could afford one at my age (23) but this one popped up in my price range. The car needs a lot of work but it runs and drives. So far I like it, it is very comfortable but I need to start sorting out the electrical nightmare

Here's a list of problems I know of so far:
-Doesn't start immediately when cold, but it does after a minute or so.
-Shifting is a little rough, not terrible but I have felt smoother
-Dash lights don't work
-Tach doesn't work
-Cruise control doesn't work
-Sunroof stopped working an hour after I bought it lol
-Driver side pass. window doesn't roll down.
-Missing the door lock "pole" that comes out of the door to push down or pull up (Driver door)
-Key fobs don't work
-Has a couple of dash lights on (ABS, a lightbulb looking one, and one I can't remember at the moment).
-Head unit doesn't work, but it is some walmart-ish deal so it could be the unit itself.

It's pretty rough, but when it is up and running it feels solid and rides nice. I am hoping that at least some of those issues are a simple fuse or battery away from working, but I doubt that haha. Other cars in my price range were up around the 200k mark for the most part. I figure for the mileage it is worth driving it even if I don't fix a thing. I'll get pics up as soon as I have a chance to get some daylight pictures!

This looks like an active forum, I'm excited to read more on here.
Levi B is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-29-2012, 09:28 AM
BenzWorld Newbie
 
Date registered: Oct 2012
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi and welcome ohh nice you buy for 2700$

http://www.centplay.com/affiliate/games_4320/

Last edited by amzee84; 10-31-2012 at 09:22 AM.
amzee84 is offline  
post #3 of 6 (permalink) Old 10-29-2012, 09:49 AM
BenzWorld Veteran
 
NYYYCE&EEEEZY's Avatar
 
Date registered: Oct 2012
Vehicle: 1989 560SL; 2014 E350; 1960 190SL-sold; 1996 280C-sold
Location: Mid Hudson Valley, NY
Posts: 723
Mentioned: 0 Post(s)
Quoted: 136 Post(s)
It would probably be rather presumptuous of me to extend the traditional "welcome" as I am a newbie here myself, having joined only last month. Having siad that, although I'm not mechanically gifted myself, I have found in my brief time here that there are a lot of folks here who are, and I'm sure they'll be quite willing to lend a hand with the issues you have with your new ride.
NYYYCE&EEEEZY is offline  
 
post #4 of 6 (permalink) Old 10-29-2012, 06:26 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2012
Vehicle: 1990 300e
Location: Washington State
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you guys for the welcomes! I'm going to try to tackle the cold start issue first, as that's going to be a problem if it get's worse. Then I'll check into the shifting, then dash lights. At least that's the plan lol. I need to do some reading, I'm sure these issues have come up in the past and I just need to find the threads where they were discussed
Levi B is offline  
post #5 of 6 (permalink) Old 11-02-2012, 04:54 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,595
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #6 of 6 (permalink) Old 11-06-2012, 10:30 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2012
Vehicle: 1990 300e
Location: Washington State
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you!

So far I've fixed the cold start, abs light, and dash lights. I'm planning on fixing the hard shifting this weekend (provided I can get parts) and detailing the exterior. I will definitely take before/after pics as my paint is in pretty bad shape - not hoping for a miracle but I do want some improvement haha.

Perhaps I should do some kind of boringly slow member's journal type of post? I'll look into it.
Levi B is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome