Srs light and no acceleration...Limp home mode????? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-24-2012, 04:39 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2012
Vehicle: 1995 E320
Location: Maryland
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Srs light and no acceleration...Limp home mode?????

I have 95 e320, while dri ing my srs lighg came on at a stop and then i had had no acceleration. I pulled over turned car off and on them the srs light went off and car drove normal. Today it happened again and the light is on, won't go off and car is in one gear. I heard.of limp home mode and don't know what to do our how to get sts disabled. Thanks all, don't have the money to get nothing done so need some help.

Sent from my SPH-D710 using AutoGuide.Com Free App
Spicealata is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-24-2012, 05:36 PM
DrX
BenzWorld Elite
 
DrX's Avatar
 
Date registered: Aug 2006
Vehicle: 2002 ML320, 2003 A160
Location: Brisbane, Australia
Posts: 3,460
Mentioned: 2 Post(s)
Quoted: 456 Post(s)
If you can afford to put gas in your car, you can afford to visit an indy mechanic and get your codes read. Find a close one if you'll be driving there in 2nd gear.

Look up the code on p 12/2 of this document. There are tests you can do if you have an ohmmeter. Be sure to observe all precautions when working on the SRS.
Attached Files
File Type: pdf content.pdf (558.3 KB, 79 views)
DrX is offline  
post #3 of 3 (permalink) Old 10-24-2012, 09:36 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,773
Mentioned: 9 Post(s)
Quoted: 1123 Post(s)
You should post it in W124 section.
Per my knowledge 1995 is not digital car, so it is not having limp modes, but I never owned this year, so don't take my word for it.
Kajtek1 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome