Egine light? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-19-2012, 12:24 AM Thread Starter
BenzWorld Junior Member
 
mahocnc's Avatar
 
Date registered: Oct 2012
Vehicle: 2013 ML350 BlueTEC 4 MATIC
Location: Edmonton Canada
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Egine light?

On a new vehicle with 600km
it was checked out as...
maximum actuation duration for zero quantity for fuel injector of cylinder 2 exceeded.

the mechanic thinks of 0 concern,..thinking of software problem, he said that most likely light will not come on again,...but it did, 10 min. after driving away.
Any idea,..did it happen to you??
mahocnc is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-19-2012, 02:49 AM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,052
Mentioned: 18 Post(s)
Quoted: 922 Post(s)
Lifetime Premium Member
Get it back to the dealer and if the do not attend to it get MB of Canada involved.

Clearly the car has a problem.

A fault with a diesel injector can destroy the associated piston/cylinder quickly.
Noodles is offline  
post #3 of 10 (permalink) Old 10-19-2012, 10:44 PM Thread Starter
BenzWorld Junior Member
 
mahocnc's Avatar
 
Date registered: Oct 2012
Vehicle: 2013 ML350 BlueTEC 4 MATIC
Location: Edmonton Canada
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you noodles!

They insisted to bring it in again for "another" diagnostic,..I said for WHAT, it'll be the same. Sure enough, it was the same today, .. they said, next Tuesday they will get back to me. He was talking about that it might need another injector. If this happens, should I be concerned of something else besides messing with the engine.? ..I have very little faith in mechanics. Light came on again after 10min.
mahocnc is offline  
post #4 of 10 (permalink) Old 10-20-2012, 03:30 AM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,052
Mentioned: 18 Post(s)
Quoted: 922 Post(s)
Lifetime Premium Member
I would not worry too much at this point. You are acting soon enough for any serious harm to happen. However stay on them.

For all we know a bad batch of injectors made it down the assembly line. We will never know.
For what you paid and how few KMs are are on the car they need to handle it now and keep at it until it is fixed. If the next repair does not fix the problem, drop it back off and tell them you do not want back until it is 100% fixed. That is your right under warranty.

I do not know what Canadian Lemon Laws are, but if this keeps on for a month or two I would start looking into them.
Once the dealer and MB gets a whiff of that action they you will have their full attention.
At this point any threat of action would be very premature, but make sure MB does not stick you with a lemon before it is too late. So getting educated on your rights is a good thing to start.

I am sure each province has their own laws like each state does here.
Noodles is offline  
post #5 of 10 (permalink) Old 10-20-2012, 09:45 AM Thread Starter
BenzWorld Junior Member
 
mahocnc's Avatar
 
Date registered: Oct 2012
Vehicle: 2013 ML350 BlueTEC 4 MATIC
Location: Edmonton Canada
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you so much Noodles in being so helpful here and getting me educated.
mahocnc is offline  
post #6 of 10 (permalink) Old 10-20-2012, 10:07 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,756
Mentioned: 9 Post(s)
Quoted: 1120 Post(s)
Quote:
Originally Posted by mahocnc View Post
..I have very little faith in mechanics. Light came on again after 10min.
So have I. It is pretty common that the car taken once to the shop for a repair, in mysterious way has to come back for another repair few months later.
Our original ML was never touched by professional mechanic beside few warranty glitches and run perfectly for 12 years, even those years had pretty s**ty reliability records. I call it mechanics reliability not the car.
But your car is new and you have not too many choices. Injectors for newer diesels are about $600 a piece >>> not something you want to cover out of pocket based on low trust.
Have a "nice" talk with SA.
Kajtek1 is online now  
post #7 of 10 (permalink) Old 10-21-2012, 10:12 AM Thread Starter
BenzWorld Junior Member
 
mahocnc's Avatar
 
Date registered: Oct 2012
Vehicle: 2013 ML350 BlueTEC 4 MATIC
Location: Edmonton Canada
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Kajtek1 View Post
It is pretty common that the car taken once to the shop for a repair, in mysterious way has to come back for another repair few months later. .

Isn't that the truth! .. Thank you Kajtek1
mahocnc is offline  
post #8 of 10 (permalink) Old 10-21-2012, 09:50 PM Thread Starter
BenzWorld Junior Member
 
mahocnc's Avatar
 
Date registered: Oct 2012
Vehicle: 2013 ML350 BlueTEC 4 MATIC
Location: Edmonton Canada
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Guess what,..today the engine light turned off by itself!

What would this mean??
mahocnc is offline  
post #9 of 10 (permalink) Old 10-21-2012, 10:47 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,756
Mentioned: 9 Post(s)
Quoted: 1120 Post(s)
Quote:
Originally Posted by mahocnc View Post
Guess what,..today the engine light turned off by itself!

What would this mean??
That means that the problem did not reoccurred for some time, or some number of restarts.
Could be that you had bad fuel, or water in the fuel?
Keep your fingers crossed.
Kajtek1 is online now  
post #10 of 10 (permalink) Old 10-22-2012, 12:41 AM Thread Starter
BenzWorld Junior Member
 
mahocnc's Avatar
 
Date registered: Oct 2012
Vehicle: 2013 ML350 BlueTEC 4 MATIC
Location: Edmonton Canada
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Oh wow....you might have hit the nail on the head.

This is also what the mechanic said. I said, perhaps you guy's gave me bad fuel,...the tank was low, just about to get filled up the first time from me, said that I will get better fuel,...he laughed. Thank you!
mahocnc is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome