Car reverse but wont accelerate..Help please.. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-18-2012, 03:25 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2012
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Car reverse but wont accelerate..Help please..

Hello all. I have a 1994 Mercedes Benz C220. It was a gift to me on my birthday. After a few months of driving it, my car won't accelerate no more but revs and if I tap on the gas petal it moves forward by a bit. The car still reverse. When the issue started on driving it on D gear because it won't accelerate, and I was at work so I had to drive it on gear 1, 2 and 3 to get home and it was fine. Then one day the car shut off on me while stopping at a stop sign. Got it towed to my house. Got it started again...but it wont accelerate in any gears besides on reverse. As people instructed me of the problems (supposedly) I had my transmission fluid flushed and replaced/filled, new fuel pump, new spark plugs, oil changed. Problem was car said unleaded gas only and I was told that cheap gas could be pumped in there and the owner before me been doing it for 2 years. So i have been using cheap gas....Radiator has a small drips of leak and looks like there's some black residue in the radiator tank. There were 2 times when the engine shakes while driving....gas petal is 1 inch off from the floor...I was told by car shops I need a new transmission which I don't believe...there are other ways around in fixing this...someone, anyone or everyone...please guide me on bringing this car a live again....I don't make much money and new transmission cost $2,500 as I was told...I know there's still hope...please help me..thank you and god bless you all.

Please guide me to what needs to be replaced, fixed..etc..I don't have enough money to pay car repair shops. I want to fix this on my own..also when I flushed the transmission fluid, it looked fine and didnt smell bad..also on the dip stick, it says 30 - F - 90.Since I poured in new transmission fluid, does the F means "Full and it's at the correct level?... Thanks all for the help.
Atlantica is offline  
Sponsored Links
post #2 of 2 (permalink) Old 09-18-2012, 05:55 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
Please scroll down to the sedans section to find your model specific forum and ask there. Welcome and good luck.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome