help needed please - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-10-2012, 10:50 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2012
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
help needed please

hello i currently have a problem with my ml 270. I went in to the glove box and the bulb sparked and now the cd player doesnt work and the parot system doesnt work or the bulb. it is not blown but no power getting to the bulb. i didnt no if that maybe there is a relay or something that could have blown or something else that my of tripped because of this. but there is power getting to the cd player as when hit eject the cd comes out. i have checked all of the fuses as i thught this would be the problem but they are all ok

any one had this problem if so how was it solved?

many thanks
karen_fryett is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome