vacuum pump - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-09-2012, 12:20 AM Thread Starter
BenzWorld Member
 
Date registered: Jun 2009
Vehicle: 1977 300D mercedes w123 4 door sedan
Location: Northern Iowa
Posts: 65
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
vacuum pump

I just got my old 1977 Mercedes 300D out of storage. Put new diapham and check valves in vacuum pump. Hooked tester to brake booster line while running. Now the tester is acting erratic. It jumps back and forth between 0 and normal range. Could I have put the 2 check valves in wrong? 1 points up 1 down. I hate to take it all apart again. Tough getting fan back on and off. The vacuum pump has 2 ports one to brake booster. One to air intake.W123
chronic is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome