Can not pump the gas to full tank - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-29-2012, 10:04 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Can not pump the gas to full tank

I have a MB E 350 2008.

Recently having problem when pumping gas, set the pump to automatic, it can only pump the half tank then the handle release like the tank is full. Trying to pump again by hand and it can slowly fill in but it will take the very long time to fill up the tank.

Does anyone have the same problem or does anyone know what is the problem?

Thanks.
spotty_29 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-30-2012, 06:56 AM
BenzWorld Member
 
xrayaz's Avatar
 
Date registered: Dec 2006
Vehicle: 1988 560SL 71000mi, 2015 S550 4Matic
Location: Phoenix, Arizona USA
Posts: 194
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have had that problem a few times and it was the fault of the large rubber vapor recovery system on the pump handle. At some stations I have to hold it back with my hand or the car will not fill correctly.
Michael in Arizona

1988 Signal Red 560SL
2015 S550 4Matic Ruby Black/Beige
xrayaz is offline  
post #3 of 5 (permalink) Old 08-30-2012, 11:48 AM
BenzWorld Junior Member
 
Date registered: Aug 2012
Vehicle: 2012 C250W Sport
Location: MA, USA
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
xrayaz is correct, the problem lies with the junction between the pump handle and our gas tanks. Maintaining a slight offset between the two solved the issue in my case (by holding the handle manually). However, this isn't a problem in my location as all automatic pumps are now gone so you have to hold the handle anyway :/ You'll have to suffer like us I'm afraid haha
AK4749 is offline  
post #4 of 5 (permalink) Old 08-30-2012, 12:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by xrayaz View Post
I have had that problem a few times and it was the fault of the large rubber vapor recovery system on the pump handle. At some stations I have to hold it back with my hand or the car will not fill correctly.
Michael in Arizona
Thanks. But I did not have this problem before, now the 4-year warranty is over... the problem starts.

Can the dealer do something to solve the problem or do we have to live with this from now on?
spotty_29 is offline  
post #5 of 5 (permalink) Old 08-30-2012, 12:16 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by AK4749 View Post
xrayaz is correct, the problem lies with the junction between the pump handle and our gas tanks. Maintaining a slight offset between the two solved the issue in my case (by holding the handle manually). However, this isn't a problem in my location as all automatic pumps are now gone so you have to hold the handle anyway :/ You'll have to suffer like us I'm afraid haha
Thanks. I can only hold the handle and press a little to get the gas going to the tank. It takes forever to fill up....
spotty_29 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome