Transmission Problem????? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-20-2012, 03:45 PM Thread Starter
BenzWorld Member
Date registered: Jun 2009
Posts: 53
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Transmission Problem?????

I have a 06 SL500. On Thursday of last week I took my car in to get it smogged. That morning when I turned the key on I got a red message on the speedometer saying "Brake" and another red message under the tach saying "Reduced brake effect start engine" (I also got the same messages this morning). When I started the car the message went away and I drove into town to the SMOG place. The car passed the test and I left. After I left the SMOG shop within a quarter of a mile I noticed the car wasn't upshifting and I had a yellow message saying, "Check Engine." I pulled over and tried different things and nothing seemed to help the problem so I drove home slowly. When I got home I threw my code reader on the car and got the code P0798. I also noticed when I got home that shifting the car into forward or reverse from park was jerky/snappy.

Again, the symptoms I'm experiencing are the transmission stays in 1st gear no matter how fast I go and only first, reverse and park work. The check engine light is on as well and I’ve gotten that Brake Message twice (once today). Additionally, the car jerks when I put it in drive or reverse.

I am certain the SMOG shop didn't do anything that could have caused the problem. The only think the SMOG guy did was remove the front engine cover.

In looking up the code (P0798), while there was a list of five things, it said the most probable cause of the code was the pressure control solenoid valve circuit is open or shorted. However, I don't understand why I'm getting the red brake message and in talking to the owner of a small Mercedes Shop in town he said it might be something like a circuit board or some other electronic device.

Has anyone ever experienced this kind of thing?


06 SL500 w/AMG Sports Package
I LOVE IT!!!!!!!
hooperdoski is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome