In need of help... - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-19-2012, 01:27 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2012
Vehicle: 1982 380 SL
Location: Orange County, CA
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
In need of help...

I inherited my father-in-laws 1982 380SL after he passed away two years ago. I knew at the time the there was some major issues coming up, things he had not been able to get serviced or repaired. During a service check at the shop he would go to for general repairs, I found out that the entire exhaust system from the down pipes to the tail pipe are corroded and or rotted out(1700 is the cheapest I have found for this, to keep it a dual pipe system, otherwise the single pipe replacements tend to burn out too quickly and dont pass smog and you're stuck redoing it again). They also told me what they had told hime, the the fuel management system needed to be repaired, but it would cost 2k because no one here in the state did it anymore, only place to get one was the dealerships. While trying to drive it only locally as my only vehicle, the power got noticeably more sluggish, smoking heavily, and a secondary inspection told me that the number 7 piston was being flooded by the failing fuel management system, causing more stress to the engine overall. The vehicle has since been in storage, only running the engine to keep battery charged once a week. The shop at the time said they could help me with some discounts if the work was done all at once, but the estimate was 6-6500 for the job. While I have since tried to call around, the cost for the repairs keeps going up, with more and more referrals to dealerships to get the work done. I have been looking through the blogs here, but it gets more and more confusing. Any suggestions?

Thanks,
Leo
curefan is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-19-2012, 06:45 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,590
Mentioned: 3 Post(s)
Quoted: 311 Post(s)
Ask the experts on this model, here is a link;

R/C107 SL/SLC Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is online now  
post #3 of 3 (permalink) Old 08-22-2012, 10:48 AM
BenzWorld Newbie
 
Date registered: Aug 2012
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have a 1995 sl500 that needs a engine harness....any suggesstions
randy vancouver is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome