2002 ML320 wont start - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-18-2012, 09:52 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2012
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2002 ML320 wont start

I have a 2002 ML320 that wont start. My wife normally drives it and a few times she has said that it would start then sputter and die. That was a few weeks ago since then we have not had any problems. Today i took it to the store and noticed that the low fuel light was on. Made it to the store and came back out and it would turn over but not start. I then put some gas in it thinking that was the problem. Once i put the gas in it started and ran fine for a few minutes. then when i was going through an intersection on the way home it died. I tried to start it again and it started for a second then died again. Since then it will not start and it will just turn over. I am not sure what direction to go. Can someone give me some ideas? If its a fuel pump or fuel filter are those something i can do my self? Also may it be a ignition switch, camshaft sensor, or relay somewhere?
jmulli13 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-19-2012, 05:12 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,187
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
It is behaving just like the fuel pump is going out. If it was a crankshaft position sensor it would die when hot and not start until it cooled down.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome