Problems with my 88 300E - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-02-2012, 07:05 AM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2012
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Problems with my 88 300E

I'm having problems with my 88 300E. Lately if I've been driving it for a couple minutes, I get problems with the car starting to sputter and run really rough. Mainly at low speeds, but I can feel that it's not quite right at higher speeds as well. If I let the car sit for awhile, it will be running fine the next time I get in until I've driven it for a little bit. I was living with the problem fine for awhile, but eventually it cut off on me at a stop light and would not crank. It turned over just fine, but would never fire up for more than just a cough. After letting the car sit for a couple hours, it cranked fine and I drove it home. I took it to a mechanic who works on Mercedes and he didn't seem to know what the problem was. He replaced the fuel filter and did a couple other small things, but three days after I got the car back, the same thing happened again. I have noticed that the problem seems to be worse if I let the car sit all day the day before without driving it at all.

I've been pouring over threads on this site and it seems that the mostly likely causes are the OVP or the fuel pump. I do have my ABS light come on regularly, but it doesn't stay on at all times. I'm thinking about getting some used parts and just replacing the OVP and fuel pump both to see if that will fix the problem. Is there anything special to know about replacing the fuel pump? The OVP seems pretty straightforward. Also, is it worth replacing the fuel relay while I'm at it? Any help is appreciated.
tadghostal789 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-02-2012, 07:31 AM
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 64,125
Mentioned: 2 Post(s)
Quoted: 991 Post(s)
Lifetime Premium Member
80% the problem is the OVP. Replace it with a NEW one, don't even bother putting a used one that could be faulty and you will end up chasing the problem for a long time.
The OVP should simply be a maintenance item that needs to be replaced every 5 to 7 years. If your ABS light comes on, this is another indicator that the OVP is toast. Don't just replace its fuse, get a NEW OVP.
DP is offline  
post #3 of 4 (permalink) Old 08-02-2012, 07:35 AM
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 64,125
Mentioned: 2 Post(s)
Quoted: 991 Post(s)
Lifetime Premium Member
Replace the fuel relay if you're not getting gasoline to the engine. You seem to get gas but to truly test for fuel delivery, you can remove the fuel relay, bypass it by jumping the two pins that will start the fuel pump. Do that after you replace the OVP, so that you're not dealing with two combined problems.
Next, while you're at it, check your fuel pressure with a CIS tool. That would indicate if your fuel pressure regulator is working fine and if your fuel distributor is doing its job. Next, check the EHA for leaks.
DP is offline  
post #4 of 4 (permalink) Old 08-02-2012, 07:36 AM
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 64,125
Mentioned: 2 Post(s)
Quoted: 991 Post(s)
Lifetime Premium Member
For more tips go the W124 subforum on this site. The guys/gals in there are far more knowledgable and are very helpful.
DP is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome