New '89 Mercedes 190e 2.6 Owner (with a few questions) - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-01-2012, 11:19 PM Thread Starter
BenzWorld Newbie
 
ti11man21's Avatar
 
Date registered: Aug 2012
Vehicle: 1989 Mercedes 190e 2.6 (w201)
Location: Southern California
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post New '89 Mercedes 190e 2.6 Owner (with a few questions)

I was lost, deep in a fruitless search for a fun, well-sorted automobile produced by the ubiquitous Bavarian Motor Werks during the 1980's. Tirelessly I test drove beater after beater; one might have been a ghetto-fied shell of a 325e, another may have been a terrible 533i worth less as a whole than the parts it was missing.

Eventually, I grew tired of this search for a worthy 3-/5-series for less than $2,000, and began looking elsewhere for means of entertaining transportation. Toyota Supra - too small (and plasticy). Honda Prelude - too boring. Audi - too unreliable. This car search was really starting to wear my patience thin, when I finally decided to type "mercedes" into the Craigslist search bar.

After a mere 30 seconds of scrolling, I stumbled upon a wonderful blue 1989 190e, with an incredible 98,000 original miles. Of course, I scrambled for the telephone, and that day made the journey to take a look at the little car. The interior had seen better days, and the Automatic Transmission was a major turn off, but I decided on the spot that buying a car famous for superb build quality while it only had 98,000 miles on its (functioning) odometer, and for only $1800, would be a wise decision.

So far I really enjoy the car; it's smooth, fast in a pinch, tail happy in a lovely and controllable way, humble, and unique. But even with the low mile count, I've uncovered a few issues that I would love some help with.

1. The Automatic Transmission has a tendency to slam itself into gear, especially when cold. I put a bottle of LUCAS stop-slip in, but it's made a marginal difference thus far.
2. The car won't pass smog, and the smog test guy said he saw smoke coming from underneath the car.
3. The gas pedal seems loose, and I have to push the accelerator down about 1/3 of the way for anything to happen. I'm guessing Throttle Cable needs adjustment?
4. Trunk won't centrally lock (fuse?), and rear dome light doesn't work (fuse?)
5. Every once in a while I'll hear groaning from the rear when I go over bumps or take turns (Suspension/loose spare tire/?)


Any help/direction to prior & relevant posts would be much appreciated.
ti11man21 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-02-2012, 06:44 AM
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 64,290
Mentioned: 2 Post(s)
Quoted: 1065 Post(s)
Lifetime Premium Member
1. It could be the modulator but typically if a transmission was abused you will get that slam and it's just a matter of time before you're left stranded. Replace with a rebuilt one and you're still ahead financially given the car quality and value.
2. Failing smog could be a series of issues. You will have to be specific, like get some readings to show if it's high in CO, and other gases.
3. Cable If not, you have a vacuum leak
4. It's possible that the latch for the trunk isn't connected to the vacuum activator. Typically a link is either missing or broken.
5. If it's not the struts then it's the rear subframe mounts.

For more info, go to the W201 subforum and post this again.
DP is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome