please help 320 hot as hell - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-30-2012, 01:53 PM Thread Starter
BenzWorld Newbie
Date registered: Jul 2012
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
please help 320 hot as hell

help me PLEASE i have a 1998 ml320
Due to the fact the AC is not working... I have taken it to a garage... system is fully charged !!! C fans will NOT turn on and compressor will NOT run The mechanic put tested to power wrest on compressor with AC in ON mode... there is power to compressor but fans DO NOT RUN and compressor does not come on. Mechanic thins it is a bad compressor.

Please help Thanks
Green320ML is offline  
Sponsored Links
post #2 of 3 (permalink) Old 07-30-2012, 04:00 PM
BenzWorld Member
Date registered: Jul 2012
Vehicle: 2000 ML320, 2008 ML63
Location: Rosedale, NY
Posts: 54
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
have a compressor for a 2000 ml320

hey, i have a AC New rebuilt compressor kit i bought but never used since my 2000 Ml320 broke down the same week i bought it, needs new fuel pump. kit includes new compressor, oil, and drier expansion tank. $300 is what ill offer it to you for, since its literally brand new still in the box, and by the time i get the fuel pump fixed it'll be winter and wont need it. and have you checked your fuses, maybe its blown?
GoldML63AMG is offline  
post #3 of 3 (permalink) Old 07-31-2012, 06:26 PM
BenzWorld Member
Date registered: Apr 2009
Vehicle: 1999 E300TD
Location: PA
Posts: 167
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Green, it is possible you have an internal problem with the compressor. The fans will not turn on until the demand is there when they are needed. There is an upated harness for your fans. In the left side engine compartment fusebox , you need to locate the 30 amp fuse that controls the fans. If its blown, there is an updated harness and higher amp 40 fuse to prevent the fans from not working again. You could have more than one problem here, you need to get the compressor on first, but I was just throwing out the fan issue there since ive fixed a few hundred of them
saleen1276 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome